different size images in Slideshowkit

GoLive Actions and Extensions - support, comments and suggestions.

different size images in Slideshowkit

Postby Tony_nz » 02/28/2008 @ 17:38

I'm using slideshowkit 1.5 for the first time, and basically, it is great - does everything I want it to. However I have one problem. The images in the slide show are of differing dimensions. In most browsers, this doesn't seem to be a problem - the images all display at the appropriate size. However in Safari/WIN it looks like the display dimension is governed by the size of the first image, and subsequent images are stretched/distorted to fit.

I realize this is a Safari/Windows problem rather than Slideshowkit, but is there any way I can impose a dimension on the images, or alternatively force Safari to do what I want?

Although I have been a programmer for many years, I am a newbie to Javascript, so if the solution lies there, please use words of one syllable! :)
Tony_nz
 
Posts: 4
Joined: 02/28/2008 @ 17:27

Re: different size images in Slideshowkit

Postby Nate Baldwin » 02/28/2008 @ 18:14

For the slideshow base image on your page, do you have a size set, or is it set to "image"? A less than perfect option is to add padding to your image files to match the page background so they're all the same pixel size... but would be better if we can get Safari to play nice. A link to your page might also help?
Nate Baldwin
Site Admin
 
Posts: 3724
Joined: 04/25/2003 @ 19:05

Re: different size images in Slideshowkit

Postby Tony_nz » 02/28/2008 @ 18:41

Thanks for the swift response. I have no size set on the image. You can see the page at http://www.ceramics.co.nz/newsite/TakeTheTour/TakeTheTour_studio.html. I was looking at it locally earlier, which is why I didn't post the URL then.

How do I properly post a link? I tried using BBC code and it was rejected.
Tony_nz
 
Posts: 4
Joined: 02/28/2008 @ 17:27

Re: different size images in Slideshowkit

Postby Nate Baldwin » 02/28/2008 @ 22:26

I don't think the forum is allowing "real" links because of all the spam... I took a look at your page and everything seems fine on that end. It resized OK in Safari, but it's the Mac version. I'm probably going to have to just call it a Safari Windows Beta bug, sorry (can't really afford to devote time right now updating the action code, if it's even fixable).
Nate Baldwin
Site Admin
 
Posts: 3724
Joined: 04/25/2003 @ 19:05

Re: different size images in Slideshowkit

Postby Tony_nz » 02/28/2008 @ 22:52

Thanks for taking the time to look at it at all. I just need to decide now how big my Windows/Safari userbase is likely to be - minuscule, I suspect, which means I'll probably just add a caveat to the page for Safari/Win users.
Tony_nz
 
Posts: 4
Joined: 02/28/2008 @ 17:27

Re: different size images in Slideshowkit

Postby Tony_nz » 02/29/2008 @ 02:28

All solved - I downloaded the latest version of Safari and the problem went away. A combination of your comment about beta bugs and feedback I got from this forum:

http://www.pressf1.co.nz/showthread.php?p=649037#post649037

They are a great community for solving computer (and non-computer) problems.

Thanks again for your help.
Tony_nz
 
Posts: 4
Joined: 02/28/2008 @ 17:27


Return to GoLive Actions and Tutorials



Who is online

Users browsing this forum: No registered users and 2 guests

cron