"Back to form" resets fields in IE

NateMail, ProcessForm, JavaScript Form Validator, Form Security, etc.

"Back to form" resets fields in IE

Postby trx » 10/02/2005 @ 03:00

After validating a form, the "Back to form" returns to the form. The filled fields however are reset to blank in IE. They are filled if using FireFox. I get the same behavior if I use the browser's Back button.

I would like the filled fiels to retain theit content after validation.

Thank you.

TRX
trx
 
Posts: 2
Joined: 10/02/2005 @ 02:54

Postby Nate Baldwin » 10/02/2005 @ 15:18

That behavior is controlled by the browser, I'm afraid. To have the entered values load back in without depending on the browser, you'd need to either script the form page to re-enter the values (that would need stored in a session or cookie), or more simply, you could use JavaScript validation to check the form out before it is submitted. If the JavaScript runs with the form is submitted, it could cancel the submission and the form wouldn't lose any values.

If the validation is relatively simple, this might help...
http://www.mindpalette.com/tutorials/va ... vanced.php

What I like to do is use JavaScript validation because it's easier for the visitor (like in Explorer where it loses the form values), and then back that up with server-side (NateMail or ProcessForm) validation for those few users with JavaScript disabled.
Nate Baldwin
Site Admin
 
Posts: 3724
Joined: 04/25/2003 @ 19:05

Postby trx » 10/03/2005 @ 19:13

Thanks a lot. That really helps! Keep up the good work.
trx
 
Posts: 2
Joined: 10/02/2005 @ 02:54


Return to Form Processing (NateMail, ProcessForm)



Who is online

Users browsing this forum: Exabot [Bot] and 0 guests

cron